Version 8.5.1 of Zend Server for IBM i incorrectly displays version 8.6.0 in Licensed Program description

Follow

Issue

Zend Server for IBM i version 8.5.1 incorrectly displays as version 8.6.0 on the "Display Installed Licensed Programs" display.  This can prevent updates to later versions.  The update job log may display this error:

This PTF can be applied to Zend Server version 6, 7 and 8 only

Environment

Zend Server 8.5.1 running on any supported version of IBM i.

Resolution

When checking the version of Zend Server for IBM i, one way to do it is to use GO LICPGM option 10 to display the description:

Determine Which Version of Zend Server for IBM i is Installed

If the version displayed is 8.6.0, this is an error.  There is no version 8.6.0 of Zend Server for IBM i.  This is really version 8.5.1.  This would be considered a cosmetic error, except for the fact that the later version updater for 8.5.3 checks the installed version and halts due to 8.6.0 being greater than 8.5.3.  Fortunately, it is easy to fix this.

From the command line:

go licpgm

Use option '10. Display installed licensed programs'.

Scroll down (usually to the last page, or next to last page) to find product 6ZSVRPI. The description will tell the version of Zend Server and the version of PHP installed.

If the version says 8.6.0 like this:

6ZSVRPI   *INSTALLED   Zend Server for IBM i 8.6.0 ( PHP 5.6)

Then the fix command should be run.  If so, return to the menu, and on the command line, please run this command:

CHGMSGD MSGID(ZCM0001) MSGF(ZENDSVR6/ZSVRMSGF) MSG('Zend Server for IBM i 8.5.1 ( PHP 5.6 )')

After running the command, please use option 10 again and verify that the description is changed.

Have more questions? Submit a request

Comments

Powered by Zendesk