Zend Server on OS X 10.11 "El Capitan"

Follow

Summary

With the release of OS X 10.11 "El Capitan", users started upgrading from earlier OS X versions (mostly from 10.10 Yosemite).

Once upgrading a machine with already installed Zend Server, there might be problems breaking functionality of Zend Server.

Actions Required

If problems occur and cannot be fixed easily by checking the logs and changing configuration / permissions etc, Zend recommends to download fresh packages from the Zend Server website to perform one of the following:

1. Reinstall of the fresh package (PHP 5.5 or 5.6) so the files are being replaced on the spot (recommended if you wish to try and keep the working setup with the newly upgraded OS).

2. Remove (sudo /usr/local/zend/bin/uninstall.sh) and install a fresh copy of Zend Server (recommended in case there is nothing important to keep from the old install or you wish to start fresh).

Conclusion

At the end of the above actions, you should get a working Zend Server on your OS X 10.11 "El Capitan".

If there is still a problem after installing the latest Zend Server packages from zend.com, please open a support ticket and we'll handle accordingly.

Notes and Links

System Requirements

Release Notes

Zend Server Downloads

Zend Studio and Zend Server integration

If you also use Zend Studio and fail to detect local Zend Server after reinstallation, please see this KB:

Cannot-Complete-Local-Zend-Server-Auto-Detection-From-Zend-Studio

Have more questions? Submit a request

Comments

Powered by Zendesk