IBM i V6R1 (or 6.1) is not supported in Zend Server 8.5 or later

Follow

Issue

Zend Server 8.5 for IBM i no longer supports V6R1, also called 6.1, even though V6R1 IBM end of support date is not until September 30, 2015.  Why did Zend drop V6R1 support in Zend Server before the IBM EOS?

Environment

Zend Server 8.5 or later, IBM i V6R1 (or 6.1)

Details

In the spring and summer of 2015, as Zend Server 8.5 was in development, there was a great deal of concern about the security of TLS 1.0 and older versions of SSL encryption protocols.  Some browsers became configurable to reject all SSL encryption protocols other than TLS 1.2.  It became important to get TLS 1.2 support into all OS editions of Zend Server, including Zend Server for IBM i.

In order to include TLS 1.2 support in Zend Server, OpenSSL must be at a high enough version to support TLS 1.2.  On the IBM i, OpenSSL is distributed by IBM as part of the 5733SC1 Licensed Program package.  On 7.1 and 7.2, the version of OpenSSL included is TLS 1.2 compatible.  However, the version of OpenSSL distributed for V6R1 is not TLS 1.2 compatible.  So, when we compiled TLS 1.2 support into Zend Server for IBM i, we lost compatibility with the version of OpenSSL distributed with V6R1.

Because TLS 1.2 is a vital security feature, and because V6R1 support was ending a couple of months after the release of 8.5.0, it was decided to go ahead and remove support for V6R1 from 8.5.0. 

IBM will end support for V6R1 on September 30, 2015:

Software withdrawal: IBM i 6.1, IBM DB2 Extenders V9.1 and V9.5, and selected IBM i services

We are aware that IBM intends to provide a fee-based extended service offering for V6R1.  Zend Server customers remaining on V6R1 extended service will not be able to upgrade Zend Server for IBM i past version 8.0.2.

Have more questions? Submit a request

Comments

Powered by Zendesk