Guard Loader Crash with Obfuscation Level > 2

Follow

Applies to:

Zend Guard Loader

Symptom

When setting 'zend_loader.obfuscation_level_support' directive with levels 2 or 3, you might get a crash instead of standard PHP output. This happens only on specific code, which involves (as far as we tested) spl_autoload_register().

Workaround

Fixed loaders are available here for the time being:

for Windows (PHP 5.5+5.6 - copy over installed Guard Loader):

http://eu-up.zend.com/files/TMP-Patched-Loader-ZS8.5.zip

for Linux and Mac (Including README and OPCache - 32/64 bit)

http://eu-up.zend.com/files/Guard7-Loader-ZS-Build-PHP-5.5.zip

http://eu-up.zend.com/files/Guard7-Loader-ZS-Build-PHP-5.6.zip

The final packages will be similar to those - for any feedback on the fixed binaries if you used them please open a support ticket for reporting.

NOTE:
This is a temporary build for anyone who has a similar symptom and the patched Loader resolves the issue. For any other problem please open a support ticket.

 

Tags: ZSRV-15213, guard, loader, crash, obfuscation, windows
Have more questions? Submit a request

Comments

  • Avatar
    John Koornneef

    Thank you. This solved my issue with zend_loader.obfuscation_level_support=3

Powered by Zendesk