Zend Server for IBM i seems to check for the wrong version of prerequisite Licensed Programs

Follow

Issue

The Zend Server for IBM i installer fails to complete if the prerequisite IBM i Licensed Programs are not installed.  When checking these programs, the installer tries to verify that they match the installed version of the IBM i operating system.  Sometimes the installer will halt on a message that indicates the installer expects the wrong version of the IBM i OS.

For example, this message was seen on a machine that was loaded with 7.1:

Product: 5722SS1 Release: V5R4M0 option: 0033 information can not be 
retrieved

The installer was looking for the V5R4 version of PASE, even though the OS was at 7.1 and the correct version of PASE was installed:

5770SS1 V7R1M0 Portable App Solutions Environment

Environment

Any version of Zend Server for IBM i installing on any supported version of IBM i.

Resolution

The installation checks data area QGPL/QSS1MRI for the OS version. Please run this command:

dspdtaara QGPL/QSS1MRI

The first six characters should correctly represent the operating system level.

In the above mentioned case where the OS was at 7.1, V7R1M0 was the expected representation. Instead, V5R4M0 was displayed in the data area.  This occurred because library QGPL was inadvertently copied over from an older V5R4 box when the customer was migrating their applications to a new 7.1 server.

Have more questions? Submit a request

Comments

Powered by Zendesk