Upgrade Zend Server for IBM i version 5 to a later version

Follow

Issue

To upgrade from version 5 of Zend Server for IBM i to version 6 or higher, it is necessary to migrate to the newer version.  This is because version 5 was created as a different Licensed Program than the newer versions.

Environment

Any point version of Zend Server 5 for IBM i needing to be upgraded to version 6 or higher, running on any supported version of IBM i. 

Resolution

Information about the migration process can be found in the online manual here:

Migrating from Zend Server for IBM i 5.x

While the current version is no longer 6, the directories for versions 7 and 8 are still named /zendsvr6 and the library name is still ZENDSVR6. The directory and library names for version 9 are zendphp7 and ZENDPHP7, and the ports are 10090 and 10091, but the rest of the directions should be mostly applicable after making those substitutions.

The first step in the migration is simply to download and install the latest available version of Zend Server.  This can be done while Zend Server 5 is running, and both Zend Server 5 and the latest version can run side by side, on the same partition, at the same time.  Here are some notes that can get you started with the installation of the latest version:

Download and install Zend Server for IBM i

 

Have more questions? Submit a request

Comments

Powered by Zendesk