IBM i Upgrading to 7.2 or higher from Earlier Versions

Follow

Issue

Upgrading the version of IBM i typically requires no configuration changes to Zend Server for IBM i, but for 7.2 there is one configuration change and a minimum version requirement for Zend Server.

This article tells how to help insure that you have a smooth transition to 7.2 for your Zend Server. 

Environment

Zend Server for IBM i any version, running on any supported version of IBM i prior to 7.2 with a planned upgrade to 7.2 or higher.

Resolution

1) Zend Server for IBM i version 7 is the earliest version compatible with 7.2.  Zend Server for IBM i version 8.5.3 is the earliest version compatible with 7.3.

If you are running version 6 or later of Zend Server, the following article can help you upgrade to the latest available version:

Upgrade Zend Server for IBM i from version 6 or 7 to version 8

If you are running version 5 of Zend Server, you need to migrate to the latest version before upgrading to IBM i 7.2 or higher.  This page in the online documentation can help you get started with the migration:

Migrating from Zend Server for IBM i 5.x

2) When you upgrade IBM i to 7.2 or higher, please make sure to apply all available PTF groups. The following article tells how to verify that your groups are current:

Verify your IBM i PTF groups are current

3) Please verify that the 5733SC1 Licensed Program version has updated to match the new OS version. This article tells how:

IBM i issues with 5733SC1, libssl.a, libz.a, libcrypto.a, or others

4) Also, you must make a change to the Apache configuration due to a change in the Apache version. Apache 2.4 changes the usage of the include directive. This article will fill you in on the details:

After upgrading to IBM i 7.2, the ZENDSVR6 Apache instance will not start

Have more questions? Submit a request

Comments

Powered by Zendesk