Zend Server daemon job ZSDAEMON is not starting automatically on the IBM i when the ZENDSVR6 subsystem is started

Follow

Issue

There is a problem in some versions of Zend Server for IBM i that can cause the Zend Server Daemon to not be flagged for start up.  Setting the flag in the menu option for Autostart Job Settings does not work.

Environment

Zend Server for IBM i, versions 6 and 7, on any supported version of IBM i.

Resolution

Please enter this command to make sure the Zend Server Daemon will start whenever the ZENDSVR6 subsystem is started:

CHGDTAARA DTAARA(ZENDSVR6/ZAUTOJOB (7 1)) VALUE('1')

Details

This error occurs in the utility to set the flags that control whether the various daemon jobs start in the ZENDSVR6 subsystem at start up.  The utility inadvertently sets the incorrect flag in the data area.  The command mentioned above will set the correct flag.

Here is a quick way to check whether the Zend Server Daemon is active.  From a 5250 command line, logged in with a *SECOFR class user profile:

go zendsvr6/zsvmenu

Use option "3. Work with Zend Server subsystems".  Select Subsystem Name ZENDSVR6, and press enter.  This will bring up the "Work with Active Jobs" display.  Please verify that the following jobs display:

ZSDAEMON     QTMHHTTP    BCI      .0  PGM-watchdog   
ZSDAEMON     QTMHHTTP    BCI     3.8  PGM-zsd        

The daemon runs at least two jobs, watchdog and zsd.  When it is active, it may be running additional jobs for additional processes, but these two should always be present.

If the server daemon is not running, you can start it without having to restart Zend Server:

go zendsvr6/zsdaemon

Use option "1. Start Zend Server Daemon".  Give it a minute to start up, then check the subsystem for the ZSDAEMON jobs to verify the daemon is started.

Have more questions? Submit a request

Comments

Powered by Zendesk