How to update Zend Framework version in Zend Studio

Follow

Applies To: 

[ Zend Studio 6.x ]
[ Windows OS ]

Overview

Zend Studio for Eclipse is supporting the latest Zend Framework and you might need the latest library code referred in your updated projects.

Note:
Since Zend Studio 10 there is a simpler workflow to add new Zend Framework code base - Creating Zend Framework Projects.

Instructions

Web Server Modifications:

In order to update the web server, you need to download and extract the ZF library to your library path, and include the new library in the php.ini include_path directive or in the beginning of your PHP code using Zend Framework

Zend Studio for Eclipse Modifications:

  1. Download and extract the Zend Framework package to your client machine
  2. Create a new ZF project and fill in the first page.
  3. Click Next - You will see a reference for FRAMEWORK_HOME to the location under Eclipse package
  4. Remove the pre-configured ZF_HOME variable - it usually defaults to %INSTALL_PATH%/ZendStudioForEclipse-6.0.0/plugins/com.zend.php.framework.resource_6.0.0.v20080107/resources/ZendFramework
  5. Add a new external folder that points to the ZF directory you downloaded on step #1. The directory should include the 'Zend' library, in ZF 1.5.1 it is the directory 'library'
  6. Your new project should include ZF 1.5.1. To verify this simply try to initiate an object of Class Zend_Layout (will not exist for ZF 1.0.3 and below).

Excerpt: Zend Studio for Eclipse is supporting the latest Zend Framework and you might need the latest library code referred in your updated projects.


Original Post Date: 2012-10-21 16:05:38

Alternative Description:

How to update Zend Framework version in Zend Studio

_____
Tags: Apple OS X,Apple OS X 10.7 (Lion),Apple OS X 10.8 (Mountain Lion),Apple OS X 10.9 (Mavericks),Debian / Ubuntu,FRAMEWORK_HOME,GNU / Linux,include_path,MacOS 10.6 and earlier,Microsoft Windows,MS Windows 2003 Server,MS Windows 2008 Server,MS Windows 2012 Server,MS Windows 7,MS Windows 8,MS Windows XP,new version,RedHat Enterprise Linux / CentOS,studio,SUSE Linux Enterprise Server / OpenSUSE,upgrade,Zend Framework,Zend Studio 7.x,Zend Studio 8.x,Zend Studio 9.x,Zend Studio for Eclipse 6.x,oldKB

Have more questions? Submit a request

Comments

Powered by Zendesk