Installation Fails Due to "Malformed uxxxx Encoding"

Follow

Applies To:

[ Zend Studio, Zend Guard ]
[ Linux ]

Symptom

You might get this output when running the installation:

An internal LaunchAnywhere application error has occured and this application cannot proceed. (LAX)
Stack Trace:
java.lang.IllegalArgumentException: Malformed uxxxx encoding.
at java.util.Properties.loadConvert(Unknown Source)
at java.util.Properties.load(Unknown Source)
at com.zerog.common.java.util.PropertiesUtil.loadProperties(Das hoA8113)
at com.zerog.lax.LAX.(DashoA8113)
at com.zerog.lax.LAX.main(DashoA8113)

Guard installer in our reproduction showed:

An internal LaunchAnywhere application error has occured and this application cannot proceed. (LAX)
Stack Trace:
java.lang.IllegalArgumentException: Malformed \uxxxx encoding.
        at java.util.Properties.loadConvert(Unknown Source)
        at java.util.Properties.load(Unknown Source)
        at com.zerog.common.java.util.PropertiesUtil.loadProperties(DashoA8113)
        at com.zerog.lax.LAX.<init>(DashoA8113)
        at com.zerog.lax.LAX.main(DashoA8113)

Technical Details

Affecting Install Anywhere - Used in products Zend Studio 5,6,7 (not in 8), Zend Guard 4,5.

To reproduce this we used an ENV var from one of our users:

$ export MYSQL_PS1="dalek mysql #\c \u@\h/\d>"
$ ./ZendGuard-5_5_0.bin

PS1 environment variable is responsible for the appearance of the command prompt in the console ('u' represents the user that is logged-on).

Apparently when you have PS1 environment variable including a 'u', the installer confuses it with a Unicode character and then fails with the installation.

Resolution / Workaround

A quick work-around would be to change PS1 to its default value or to omit the 'u' key.

You might need to clear the ENV var to execute the installer. After the product is installed, restore the ENV var to its original value.

 


Excerpt: Install Anywhere issue with PS1 ENV Vars


Original Post Date: 2011-06-14 13:17:02

Alternative Description:

Install Anywhere issue with PS1 ENV Vars

_____
Tags: Debian / Ubuntu,encoding,Install Anywhere,installation,Installer,Launch Anywhere,Malformed,PS1,RedHat Enterprise Linux / CentOS,SUSE Linux Enterprise Server / OpenSUSE,uxxxx,ZDE 5.x and older,Zend Guard,Zend Studio 7.x,Zend Studio for Eclipse 6.x,oldKB

Have more questions? Submit a request

Comments

Powered by Zendesk