mcrypt is not working in Zend Server for IBM i 7.0.0 - Hotfix 1 will fix it

Follow

Issue

After installing Zend Server for IBM i 7.0.0, mcrypt functions stop working.

Environment

 Zend Server for IBM i 7.0.0 running on any supported version of IBM i.

Resolution

The mcrypt issue was addressed in Hotfix 1 for Zend Server for IBM i 7.0.0.

Please download and install Hotfix 1 for Zend Server for IBM i 7.0.0. You can find the download available here:

Download Zend Server for IBM i

Find the Additional Downloads section. You will need to choose the correct PHP version for the Hotfix, either PHP 5.4 or PHP 5.5. It needs to be the same PHP version that is installed with Zend Server 7.0.0.  (Please see below if you are not sure of the version).

Please download Zend Server for IBM i 7.0.0 Hotfix 1 for your PHP version and unzip the downloaded file. Installation instructions can be found in the unzipped folder.

If you are not sure which version of PHP you have installed, please go to a 5250 session and enter this command:

go licpgm 

On the 'Work with Licensed Programs' menu, please use option '10. Display installed licensed programs'. Page down until you find the entry for Zend Server 7.0.0. The PHP version is noted in the description:

6ZSVRPI   *INSTALLED   Zend Server for IBM i 7.0.0 ( PHP 5.5 ) 

In this example, the PHP version is 5.5, and would require Hotfix 1 for PHP 5.5.

Have more questions? Submit a request

Comments

Powered by Zendesk